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ImageJ (FIJI) 
1. Opening and modifying the data 

ImageJ has a image processing package called Fiji (Fiji Is Just ImageJ) and it is               
available online for free download and it has many plugins. If you are going to               
open the imageJ of CNPEM, get the following directions. 

a. Opening ImageJ and loading data 
From any terminal connected to the Recon computer, open ImageJ. To do this,             
follow the commands: 

ssh –X 10.2.105.181 (Password: ask your local contact) 
imagej & 

This will open the program and release the terminal for further use. 

 
  



2. ImageJ Window 

 

a. Menu Bar (blue) 
The menu is composed of: 
File: Open/Close/Save/Export/Quit 
Edit: Selection/Copy/Paste/Undo/ROI handling 
Image: Visualization/Adjust/Crop/Transform/stack manipulation/video editing 
Process: Image filters  
Analyze: Statistics/Measures 
Plugins 
Window 
Help 

b. Toolbar (green + orange + yellow) 
These features are used for selection, measurement and segmentation. When          
used for selection, information about the measures (angle, distance, height etc)           
will appear at the ​Status Bar (Pink).  
 
See the applications of area selection/line selection/angle/point/wand tools        
(green)​  for segmentation at ​Section 7.a​.  
 
Other tools ​(orange) ​are T​ext Tool, Magnifying glass (you can also zoom in and              
zoom out clicking – or + at the keyboard),​ Scrolling tool ​and​ Color picker. 
 
Then, there is the ​macro tools ​(yellow).  
 
The last button is the macro toolset switcher (red): select a tool to add to your                
window. 
 
The search bar ​(purple)​ allows you to find tools based on keywords. 
 
  



3. File Menu: Opening Data 

Import the .b file, created during the reconstruction. Go to ​File ​> Import ​> Raw​,               
then go to the ​Sample​ folder and open it.  
 

 
 
Fill the ​Import > Raw​ window with image information: 

Image type: e.g. 8​-bit  
Width and Height: e.g. ​1140 
Number of images: e.g. 281 because this data is already cropped.  
It is typically ​2048,​ but it can be less if not all slices are reconstructed. 
Be sure that ​little-endian byte order ​and ​virtual stack ​is enabled           
(depending on the operation in ImageJ, you can’t load with virtual stack). 



 
 
This is an example of a carbonate sample. First, check all slices to ensure the               
reconstruction is as expected. If strong rings are seen or the image contrast is              
not very good, (i.e. it is hard to separate the phases of interest), there are some                
parameters on the reconstruction process that can be changed. Talk to your            
local contact, so he/she could help you. 
 
From the header (red rectangle), you get information regarding the image: the            
first information (e.g. 140/281) is the slice number shown (e.g. 140), out of the              
total (e.g. 281); the three following numbers are the size (in pixels) in X and Y                
directions, respectively. The next information is the bit depth (8-bit), followed by            
the image size (192 MB). 
 

 



4. Edit Menu 

 
 
Undo: Reverse the last action (only 1 reversion is possible – if you click more               
then one time, the tool will redo the action). Operations on entire stacks (e.g.              
filtering) won’t be reversed. 
 
Cut: Removes the area selected (and fills with the background color) and            
copies to the transference area. 
 

 
 
Copy/Paste: Copies and pastes the content – If the area is not selected, the              
program copies or pastes the entire image. 
 
Clear/Clear Outside ​- Erases the area selected and fills with the background            
color. If you activate the clear outside, the other part of the image will be               
erased. If you want to change the background color, select:          
Image>Colors>Color Picker. 
 



https://imagej.nih.gov.ez106.periodicos.capes.gov.br/ij/docs/menus/image.html 
 
Fill: ​Fills the area selected with a picked color. To pick the color, click on               
Image>Colors>Color Picker ​and select a color of your choice. Then, select an            
area and click on Fill. A dialog is displayed offering the option to fill the selection                
in all stack images.  
 
Draw: ​Outlines the selected perimeter/line.  
 
Invert: ​Reverts the image (e.g. black areas becomes white). 
 

 

a. Selection Submenu 
Some results of this features (blue) are resumed in the picture down bellow. 

https://imagej.nih.gov.ez106.periodicos.capes.gov.br/ij/docs/menus/image.html


 
 

 
https://imagej.nih.gov.ez106.periodicos.capes.gov.br/ij/docs/menus/edit.html 
 
Select all:​ It makes a rectangular selection of all the image. 
Select none: ​Clears the selection of the image. 
Restore selection:​ Redo the previous selection. 
Interpolate:​ Interpolation of pre-existing selections. 
Create selection: ​Based on a threshold image or binary mask. 



  

b. Options Submenu 

 
 
  



5. Image Menu 

 

a. Type 
In case you have a 32-bit image type, you can reduce the bit depth to 8-bit or 
16-bit. It is desirable as Avizo uses RAM memory for most of the processes. 
 

 



b. Adjust Submenu 
Before proceeding to segmentation, some adjust might be necessary.  
Select Image > Adjust > ​Brightness/Contrast 
 

 
 
A table will appear. Click on Auto and the image will get a good contrast. That is                 
mostly necessary when the histogram of your data is too narrow and you can              
barely see the sample when you upload.  
 

 
Other option is to adjust the threshold to make the segmentation easier.  
Select Image > Adjust > ​Threshold​. Select apply and then ok. 



 

 
 

 

c. Cropping the image 
Use the square tool to choose the area of interest, i.e. the area to crop. Be sure                 
that the whole image is inside the square. Check all slices by moving the bar.  
Then click on Image > Crop. Save the cropped image as a raw data (File >                
Save As > Raw Data...).  
 
As a suggestion, use the following termination: tomoXxYxZsizes_nbit.vol. An         
example of name is tomo980x1132x2048_8bit.vol.  
Image dimension and type are required information to load the data in Avizo. 
 
Observation: ​A more complete way of cropping is available. Search for Plugins            
> Stacks > Crop (3D). It allows you to crop in any direction (x, y, z). 
 
  



6. Process menu: Filters 

The options are: Smooth, Sharpen, Find edges, Enhance contrast. Once the           
hole image is filtered there is no way to reverse it. So duplicate the image to test                 
the result. Here are some examples: 
 
Smooth:  

 
Sharpen:  

 
Find edges:  

 



Observation: ​We emphasize that is not always good to filter your image if you              
plan to use it for segmentation via Trainable Weka Segmentation (the following            
section). 
 

7. Segmentation 

To start the segmentation, select Plugins > Segmentation > Trainable Weka           
Segmentation 3D. This is a machine learning tool that produces a segmented            
result based on the training of classifier. It works for 3D image. To use in 2D                
image, select Trainable Weka Segmentation. 
 

 
 
Once selected, a log table will appear (red rectangle) and there will be two              
default classifiers (yellow rectangle). To add another classifier select ​create          
new class​ (blue rectangle).  



 
 
To modify the names of the other labels, select settings and then edit the class               
names (e.g. Class 1 – Rock; Class 2 - Background). At settings you can also               
able and disable training features. You can also change the type of classifier             
(select choose). 
 
Other feature options are: ​Minimum sigma ​(minimum radius of the isotropic           
filters – by default 1 pixel). ​Maximum sigma ​(maximum radius of the isotropic             
filters - by default 16 pixels in 2D and 8 pixels in 3D). 

 

 
 
  



a. Tools 
Once the classifiers are settled, use the best segmentation tool for your            
objective.  
 

 
 
Rectangle (blue) ​- Click and drag at the image. Then click on the Rock              
classifier. It makes a rectangle. If you right click, two other options are available:              
rounded rectangle and rotated rectangle. If you double click, appears a tool to             
adjust the parameters. 

 
 
Circle (yellow) ​- Click and drag at the image. Then click on the Rock classifier.               
It makes a circle. If you right click, two other options are available: elliptical              
selections and selection brush tool. If you double click, appears a tool to adjust              
the parameters. 

 
 
Polygon (red) – It makes straight lines connected to each other to form a              
polygon. Then click on the Rock classifier.  



 
 
Freehand (green) ​– Make a form of your choice and it will fill automatically after               
you Add to Rock. 

 
 
Straight (pink) – Freehand, but for lines. Right click to other options (straight             
line/ segmented line/ freehand line/ arrow tool, and double click to adjust the             
parameters. 

 
 
Angle (orange) – Gives the angle between two points. If you add to rock, it will                
mark as a triangle. 

 



 
Multi-point tool (purple) ​- Right click to alter to Point tool and double click to               
adjust the parameters. 

 
 
Wand (tracing) (black) – It selects parts of the image connected to each other              
with the same gray or color level. That tool also allows the use of thresholding.               
Right click and select Enable Thresholding and an auto threshold will be applied             
by default. Adjust the maximum and minimum at the threshold table that            
appears. Once you apply the Threshold, the image will become black and white             
and this can’t be undone. It is worth to duplicate your image before testing (Ctrl               
+ Shift + d). 
 

 

 
 
  



Text tool – Click on the region you want to write. Double click to adjust the                
parameters. 

 

b. Training the classifier 
Segment the image adding some seeds/markers in both of the classes. Then            
click on Train Classifier. Depending on the size of the image, the process can              
take minutes to hours. The first training usually takes longer. While training, you             
will see "STOP" instead of Train classifier. By clicking on it, the whole training              
process will be interrupted.  
 

 
 
This is the first training. To see the black and white image, press Toggle              
Overlay. Make more seeds and apply train classifier until you get the result you              
expect. 
 
Observation: ​For a better training, you might need to do the annotation in the              
beginning, in the middle (preferably) and at the end (but pay attention if the              
images at the top and bottom of your sample are in a good quality, if not, crop                 
them). 



 

c. Other training buttons 
Create result:​ It displays the resulting labeled image. It is a 8-bit Color image.  

 
 
Get probability:​ It is related to the current classifier. This gives you the 
probability that each pixel belongs to each class. 

 
 

8. Saving and exporting 

To save what you have: 
Click Save Classifier, than Save Data. If you already have your final segmented             
image (create result), click on this image and then File > Save as > Choose the                
type of file you prefer. ​We suggest raw data or tiff. 



 
To open saved classifier and data: 
After Opening the data and the Trainable Weka Segmentation Plugin, click on            
Load Classifier and then load data. If your classifier have different class names,             
you need to rename them before applying the data. 
 
Then, click on train classifier. If you need, segment more and then save             
everything again. 
 

9. Batch Processing 

That is a feature that allows the application of scripts and macros in order to               
apply them for more than one image. A complete explanation about Macro            
Programming is available at:  
https://imagej.net/Introduction_into_Macro_Programming#The_recorder 
 
Basically it is a scripting language that is used to do repetitive tasks             
automatically. It applies a “recipe” to several images. 
 
First, open the data (​it can’t be a raw type​; we suggest tiff). To start your script                 
select: Plugins > Macro > Record 
 

 
 
The following table will appear. Make sure the Macro option is selected at             
Record. And alter the name if you want. 

 
 

https://imagej.net/Introduction_into_Macro_Programming#The_recorder


Then, proceed with the steps that you want to be registered: e.g.            
Brightness/contrast, crop, threshold. It will automatically appear at the table.  
 

 
 
If something that you don’t want to appear is scripted (e.g. zoom out, run              
(“close”), just select it with your mouse and then delete it. 
 

 
 

Once your done, click on Create.  Then select File > Save as. 



 
 
Close this table, the record table and the result image. To apply your scrip to               
other images select: Process > batch > Macro 
This window will appear. Select Open and then the scrip created. Then            
Process. 
 

 



 
Open the Output image: 
 

 
 

10. Using Scripts for segmentation 

At this link you can access plenty of scripts related to the Trainable weka              
segmentation: ​https://imagej.net/Scripting_the_Trainable_Weka_Segmentation 
 
In this tutorial we’ll use ​“Example: apply classifier to all images in folder”. 
First, you need to have already a .model file (after training a image, save the               
classifier). Then, copy the script and save it in a .bsh file (use a text editor, e.g.                 
Gedit).  
 
Open the ImageJ and select File > Open > .bsh file 
A table like this should appear: 
 



 
 
Click Run and then define the folder where the image you want to be              
segmented is situated, where you want the output to be saved and the .model              
file. 
 

 
 
The result image will be at your output folder. 
 
 
 
 
 
 
 
 
 


